Client Libraries (SDKs)

Mailosaur has official client libraries for various languages. We recommend using our libraries to make HTTP calls to Mailosaur.

Don’t see your language supported? Contact us.

Ruby

Available as a gem:

sudo gem install mailosaur

See the source on GitHub.

Python

Available through pip:

pip install --upgrade mailosaur

See the source on GitHub.

PHP

Available through Composer:

composer require mailosaur

See the source on GitHub.

Java

For Maven, add the following dependency to your POM:

<dependency>
  <groupId>com.mailosaur</groupId>
  <artifactId>mailosaur-java</artifactId>
  <version>7.0.8</version>
</dependency>

See the source on GitHub.

Node.js

Install via npm:

npm install mailosaur --save-dev

See the source on GitHub.

.NET

Install via dotnet:

dotnet add package Mailosaur
dotnet restore

Or using NuGet:

PM> Install-Package Mailosaur

See the source on GitHub.